Server Start

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Hey,
      Versuche gerade einen Server per PHP zu starten, allerdings will das ganze nicht so wie ich es will.

      Code:

      PHP-Quellcode

      1. <?php
      2. $output = shell_exec('cmd /K [cd C:\Users\NEIN-GUENTHER\Desktop\Lobby]');
      3. $output2 = shell_exec('cmd /K [start run.bat]');
      4. echo "<pre>$output</pre>";
      5. echo "<pre>$output2</pre>";
      6. ?>

      Als Ergebnis bekomme ich nur

      Quellcode

      1. Microsoft Windows [Version 6.1.7601]
      2. Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.
      3. C:\xampp\htdocs\webinterface>
      4. C:\xampp\htdocs\webinterface>

      Was tun?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Marcel ()

      Beitrag von MeTeor ()

      Dieser Beitrag wurde von Azure aus folgendem Grund gelöscht: Spam ().

      Beitrag von Marcel ()

      Dieser Beitrag wurde von Azure aus folgendem Grund gelöscht: Spam ().
    • Vielleicht klappt es damit?

      PHP-Quellcode

      1. <?php
      2. $query = system('C:\\windows\\system32\\cmd.exe /c C:\\Users\\NEIN-GUENTHER\\Desktop\\Lobby\\run.bat 2>&1', $stdout);
      3. // Ausgeben zusätzlicher Informationen
      4. echo '
      5. <pre>
      6. Query: ' . $query . '
      7. stdout '. $stdout .' </pre>;
      8. ?>
      Hat auch der XAMPP Anwender Zugriff auf die bat?